MetropolisOldBoys (@MetropolisOBs) profile picture

Minneapolis RFC 1960 + Metro RFC 1980 = Metropolis RFC 1992 Metropolis Metromen Rugby Forever

Minneapolis, MN, USA
Joined October 2013
Photo by MetropolisOldBoys (@MetropolisOBs)Photo by MetropolisOldBoys (@MetropolisOBs)Photo by MetropolisOldBoys (@MetropolisOBs)
Great fun today @Vikings HQ for the Inaugural Legacy Cup of the Women’s Elite Rugby Championship. Congrats to Denver Onyx in their decisive win over New York Exiles. Fantastic turnout of MN Rugby players, young /old, coaches, & fans. Can’t wait for 2026 Season. @MetropolisOBs
2
1
3
207
Great night celebrating our friends Travis and Carolyn who are leaving MN for Ocala, FL Great turnout of @MetropolisRFC and @MetropolisOBs We even had a @BansheeRugby in the mix! Great old boys event on a the rooftop of a Mpls Condo. #RugbyUnion #MidwestRugbyUnion #MNRugby
1
1
105
MetropolisOldBoys retweeted
Aussie from Perth, NZ (Hawke's Bay) parents, getting a little Aussie Rules and Rugby going...
Mitch Wishnowsky called his own number on the fake punt in the 3rd quarter. His teammates and coach react: TRENT WILLIAMS: "We didn't even get a heads up on the sideline, then all I see is the Australian strikin' down the sideline."
1
4
17
3,182
Metropolis had a great day with the D1 Men Winning 66-22 over @KCBluesRugby at home to go 10-0 & the @valksrugby won in OT in Pittsburgh. Both @MetropolisRFC D1 sides play in the @midwestrugby Championship 11/13 @ChicagoGriffins & @clrfc respectively! @MetropolisOBs @OLRFC1
1
4
Du Nord, a friend of @MetropolisRFC is a Black owned Minneapolis distillery, which started making hand sanitizer after COVID-19, and is now a food-donation center strib.mn/3742GVt #WithYou @MetropolisOBs @metrooldboy
3
4
Dear rugby, When you’re ready to start back up.... I’ll be ready! Nate Augspurger MLR 2019 San Diego Legion youtu.be/jkzzm4JGZYQ via @YouTube
1
MetropolisOldBoys retweeted
8 years ago we lifted the Junior @WorldRugby Trophy for @USARugby, over coming a talented @JRFURugby 37-33. With no Junior Trophy this year, I am so thankful that I was able to have this amazing experience with such a great group of players and friends! #USARugby #JWT #Winners – at Kildare, Ireland
4
27
MetropolisOldBoys retweeted
Serious question: How long does it take your team to get set for the group pic? #USWNTXVs
3
10
3
104
Please support those who support #MetropolisRFC like @UtepilsBrewing and #WearAMask
Wanted to give an update. Please know that, for the safety of our guests & our staff, face coverings will be required when you are not seated. You have all been rockstars when it comes to this and we can’t thank you enough! This is just a simple reminder and heads up. Cheers!
2
3
MetropolisOldBoys retweeted
Headed to The @SoCalYouthRugby Championship. Servite will be facing Carlsbad next Sunday, Feb. 23. Hosted by Major League Rugby @usmlr team, @SDLegion and a special S/O to Legion’s own, Nate Augspurger @Nthanielchannel for his support tonight 🙏🏽 Great Job Friar Ruggers #CREDO
1
10
35
THIS WKND Round 4 of @SixNationsRugby has us @britspubmpls Sat for Scot vs Wales, 8:15 am Eng vs Italy, 10:45 am Sun @KieransMPLS Ireland vs France 10 am @MetropolisOBs @valksrugby @metrowmann @UofMRugby @UtepilsBrewing @AtomicData
2
5
MetropolisOldBoys retweeted
One of the proudest days in my rugby career! Massive honor to pull on the @USARugby jersey today. Even managed to stumble over for a try. Thanks for all the messages! Now onto Argentina..
69' | FIRST CAP. FIRST TRY. @TadhgLeader finds an opening on the right flank after two breakaways from Gannon Moore and @dylanaudsley. Slots his own conversion to top it off. CONGRATS TADHG! 🇺🇸 USA 59-8 CHI #USAvCHI | #ARC2019 | @FloRugby
11
15
2
312
REMINDER from your HOF Chairman, Eric Curtin: Hall of Fame nominations are due! We extended the deadline for submitting forms through this Sunday. If submitting DM Eric Curtin ASAP to let him know of the person you are nominating, even if your full nomination form is not ready!
2
5